$re = '/(\w)(\w+(?:-\w+)*)/';
$str = 'lower case name
jean-marie
jean-marie-jean
tEST TEST-TEST-tesT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);