#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(.*?)\]\[(.*?)\]\[(.+?)(HandleUICEvent|FastNtfClosed_Line1_Common|Login|Logout)\(\)\]\[(.*?)\]$"
Local $sString = "[2019-01-02 16:15:12.424][P:1624/T:1420][UIPCallState.cpp:2099 CUIPCallTalkingLine1State::HandleSDKEvent()][Enter]" & @CRLF & _
"[2019-01-02 16:15:12.427][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]" & @CRLF & _
"" & @CRLF & _
"[2019-01-02 16:15:17.882][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Enter]" & @CRLF & _
"[2019-01-02 16:15:17.883][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Enter]" & @CRLF & _
"[2019-01-02 16:15:18.014][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Leave]" & @CRLF & _
"[2019-01-02 16:15:18.016][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Leave]" & @CRLF & _
"" & @CRLF & _
"[2019-01-02 16:21:28.013][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]" & @CRLF & _
"" & @CRLF & _
"[2019-01-02 16:21:28.039][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Leave]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")