import re
regex = re.compile(r"\[(.*?)\]\[(.*?)\]\[(.+?)(HandleUICEvent|FastNtfClosed_Line1_Common|Login|Logout)\(\)\]\[(.*?)\]$", flags=re.MULTILINE)
test_str = ("[2019-01-02 16:15:12.424][P:1624/T:1420][UIPCallState.cpp:2099 CUIPCallTalkingLine1State::HandleSDKEvent()][Enter]\n"
"[2019-01-02 16:15:12.427][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]\n\n"
"[2019-01-02 16:15:17.882][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Enter]\n"
"[2019-01-02 16:15:17.883][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Enter]\n"
"[2019-01-02 16:15:18.014][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Leave]\n"
"[2019-01-02 16:15:18.016][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Leave]\n\n"
"[2019-01-02 16:21:28.013][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]\n\n"
"[2019-01-02 16:21:28.039][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Leave]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")