use strict;
my $str = '[2019-01-02 16:15:12.424][P:1624/T:1420][UIPCallState.cpp:2099 CUIPCallTalkingLine1State::HandleSDKEvent()][Enter]
[2019-01-02 16:15:12.427][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]
[2019-01-02 16:15:17.882][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Enter]
[2019-01-02 16:15:17.883][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Enter]
[2019-01-02 16:15:18.014][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Leave]
[2019-01-02 16:15:18.016][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Leave]
[2019-01-02 16:21:28.013][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]
[2019-01-02 16:21:28.039][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Leave]
';
my $regex = qr/\[(.*?)\]\[(.*?)\]\[(.+?)(HandleUICEvent|FastNtfClosed_Line1_Common|Login|Logout)\(\)\]\[(.*?)\]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}