$re = '/\[(.*?)\]\[(.*?)\]\[(.+?)(HandleUICEvent|FastNtfClosed_Line1_Common|Login|Logout)\(\)\]\[(.*?)\]$/m';
$str = '[2019-01-02 16:15:12.424][P:1624/T:1420][UIPCallState.cpp:2099 CUIPCallTalkingLine1State::HandleSDKEvent()][Enter]
[2019-01-02 16:15:12.427][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]
[2019-01-02 16:15:17.882][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Enter]
[2019-01-02 16:15:17.883][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Enter]
[2019-01-02 16:15:18.014][P:1624/T:1420][UIPCallState.cpp:1776 CUIPCallIncomingLine1State::HandleUICEvent()][Leave]
[2019-01-02 16:15:18.016][P:1624/T:1420][UIPCall.cpp:743 CUIPCall::HandleUICEvent()][Leave]
[2019-01-02 16:21:28.013][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Enter]
[2019-01-02 16:21:28.039][P:1624/T:1420][UIPCallState.cpp:1283 CUIPCallState::FastNtfClosed_Line1_Common()][Leave]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);