package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([0-1]{8})([0-1]{24}))`)
var str = `010011011001110111100111011010001001100011101100100011100010100011110010100011001111111101101001
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}