$re = '/(([0-1]{8})([0-1]{24}))/m';
$str = '010011011001110111100111011010001001100011101100100011100010100011110010100011001111111101101001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);