// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([0-1]{8})([0-1]{24}))").unwrap();
let string = "010011011001110111100111011010001001100011101100100011100010100011110010100011001111111101101001
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}