re = /(([0-1]{8})([0-1]{24}))/m
str = '010011011001110111100111011010001001100011101100100011100010100011110010100011001111111101101001
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end