package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^._ ](?:[\w-]|\.[\w-])+[^._ ]$`)
var str = `username
Username
UserName
user-name
11username
user11name
username11
user_name
user__name
us_er__na__m_e
user.name
u.s.e.r.n.a.m.e
white space
whiteSpaceBeforeWord
whiteSpaceAfterWord
_username
_user_name
user__name_
us_er__na__m_e
user..name
.user.name
user.name.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}