import Foundation
let pattern = #"^[^._ ](?:[\w-]|\.[\w-])+[^._ ]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
username
Username
UserName
user-name
11username
user11name
username11
user_name
user__name
us_er__na__m_e
user.name
u.s.e.r.n.a.m.e
white space
whiteSpaceBeforeWord
whiteSpaceAfterWord
_username
_user_name
user__name_
us_er__na__m_e
user..name
.user.name
user.name.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)