re = /^[^._ ](?:[\w-]|\.[\w-])+[^._ ]$/m
str = 'username
Username
UserName
user-name
11username
user11name
username11
user_name
user__name
us_er__na__m_e
user.name
u.s.e.r.n.a.m.e
white space
whiteSpaceBeforeWord
whiteSpaceAfterWord
_username
_user_name
user__name_
us_er__na__m_e
user..name
.user.name
user.name.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end