import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^._ ](?:[\\w-]|\\.[\\w-])+[^._ ]$";
final String string = "username\n"
+ "Username\n"
+ "UserName\n"
+ "user-name\n"
+ "11username\n"
+ "user11name\n"
+ "username11\n"
+ "user_name\n"
+ "user__name\n"
+ "us_er__na__m_e\n"
+ "user.name\n"
+ "u.s.e.r.n.a.m.e\n\n"
+ "white space\n"
+ " whiteSpaceBeforeWord\n"
+ "whiteSpaceAfterWord \n"
+ "_username\n"
+ "_user_name\n"
+ "user__name_\n"
+ "us_er__na__m_e \n"
+ "user..name\n"
+ ".user.name\n"
+ "user.name.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}