package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)$\s*^([^"])`)
var str = `"раз два три
четыре пять`
var substitution = " \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}