const regex = /$\s*^([^"])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('$\\s*^([^"])', 'gm')
const str = `"раз два три
четыре пять`;
const subst = ` \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);