const regex = /<h([1-6])>([^<]*)<\/h([1-6])>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h([1-6])>([^<]*)<\\\/h([1-6])>', 'gmi')
const str = `<h1>Titulo</h1>
bla bla bla
<h3>Outro titulo</h3>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}