re = /<h([1-6])>([^<]*)<\/h([1-6])>/mi
str = '<h1>Titulo</h1>
bla bla bla
<h3>Outro titulo</h3>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end