#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\n)([\t ]*?)def func1 options[\s\S]*?\n\1end"
Local $sString = "def func1 options" & @CRLF & _
" some code here" & @CRLF & _
" def inner_func1 inner_options" & @CRLF & _
" some code here" & @CRLF & _
" end" & @CRLF & _
" some more code here" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"def func1 options" & @CRLF & _
" some code here" & @CRLF & _
" def inner_func1 inner_options" & @CRLF & _
" some code here" & @CRLF & _
" end" & @CRLF & _
" some more code here" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")