import re
regex = re.compile(r"(?:^|\n)([\t ]*?)def func1 options[\s\S]*?\n\1end", flags=re.MULTILINE)
test_str = ("def func1 options\n"
" some code here\n"
" def inner_func1 inner_options\n"
" some code here\n"
" end\n"
" some more code here\n"
"end\n\n"
"def func1 options\n"
" some code here\n"
" def inner_func1 inner_options\n"
" some code here\n"
" end\n"
" some more code here\n"
"end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")