import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n)([\\t ]*?)def func1 options[\\s\\S]*?\\n\\1end";
final String string = "def func1 options\n"
+ " some code here\n"
+ " def inner_func1 inner_options\n"
+ " some code here\n"
+ " end\n"
+ " some more code here\n"
+ "end\n\n"
+ "def func1 options\n"
+ " some code here\n"
+ " def inner_func1 inner_options\n"
+ " some code here\n"
+ " end\n"
+ " some more code here\n"
+ "end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}