$re = '/(?:^|\n)([\t ]*?)def func1 options[\s\S]*?\n\1end/m';
$str = 'def func1 options
some code here
def inner_func1 inner_options
some code here
end
some more code here
end
def func1 options
some code here
def inner_func1 inner_options
some code here
end
some more code here
end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);