package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]\<a[^>]+\>.+?\<\/a\>[a-zA-Z]`)
var str = `A<a href="asdfadsf">asdfasdf</a>B
B<a href="asdfasdf">sdfsdfsdf</a>C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}