// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-Z]\<a[^>]+\>.+?\<\/a\>[a-zA-Z]").unwrap();
let string = "A<a href=\"asdfadsf\">asdfasdf</a>B
B<a href=\"asdfasdf\">sdfsdfsdf</a>C";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}