re = /[a-zA-Z]\<a[^>]+\>.+?\<\/a\>[a-zA-Z]/m
str = 'A<a href="asdfadsf">asdfasdf</a>B
B<a href="asdfasdf">sdfsdfsdf</a>C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end