const regex = new RegExp('((BUY |SELL )[^\\n]+\\n)\\s+', 'gm')
const str = `SELL 2022-06-28 12:42:27 39.32 0.29 11.43180000 0.00003582
BUY 2022-06-28 12:27:22 39.30 0.10 3.93000000 0.00001233
2022-06-28 12:27:22 39.30 0.19 7.46700000 0.00002342`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);