$re = '/((BUY |SELL )[^\n]+\n)\s+/m';
$str = 'SELL 2022-06-28 12:42:27 39.32 0.29 11.43180000 0.00003582
BUY 2022-06-28 12:27:22 39.30 0.10 3.93000000 0.00001233
2022-06-28 12:27:22 39.30 0.19 7.46700000 0.00002342';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;