// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((BUY |SELL )[^\n]+\n)\s+").unwrap();
let string = "SELL 2022-06-28 12:42:27 39.32 0.29 11.43180000 0.00003582
BUY 2022-06-28 12:27:22 39.30 0.10 3.93000000 0.00001233
2022-06-28 12:27:22 39.30 0.19 7.46700000 0.00002342";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}