import re
regex = re.compile(r"((BUY |SELL )[^\n]+\n)\s+", flags=re.MULTILINE)
test_str = ("SELL 2022-06-28 12:42:27 39.32 0.29 11.43180000 0.00003582\n"
"BUY 2022-06-28 12:27:22 39.30 0.10 3.93000000 0.00001233\n"
" 2022-06-28 12:27:22 39.30 0.19 7.46700000 0.00002342")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)