using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\b[a-zA-Z0-9])\\s(?=[a-zA-Z0-9]\\b)";
string substitution = @"";
string input = @"/CY1000 HZ 23 Street Arizona
/3456 BZ 33 Rue Avenue France
/2222 6th Street Madrid
2222 6th Street Madrid
foo bar a b c d a + b
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}