# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\\b[a-zA-Z0-9])\\s(?=[a-zA-Z0-9]\\b)"
test_str = ("/CY1000 HZ 23 Street Arizona\n"
"/3456 BZ 33 Rue Avenue France\n"
"/2222 6th Street Madrid\n"
"2222 6th Street Madrid\n\n"
"foo bar a b c d a + b\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.