const regex = /(?<=\\b[a-zA-Z0-9])\\s(?=[a-zA-Z0-9]\\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\\b[a-zA-Z0-9])\\\\s(?=[a-zA-Z0-9]\\\\b)', 'gm')
const str = `/CY1000 HZ 23 Street Arizona
/3456 BZ 33 Rue Avenue France
/2222 6th Street Madrid
2222 6th Street Madrid
foo bar a b c d a + b
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);