import Foundation
let pattern = #"(?<=\\b[a-zA-Z0-9])\\s(?=[a-zA-Z0-9]\\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/CY1000 HZ 23 Street Arizona
/3456 BZ 33 Rue Avenue France
/2222 6th Street Madrid
2222 6th Street Madrid
foo bar a b c d a + b
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)