#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\* S12 \(Amount: 730\.00 USD, Special Quantity: (?<S12Quantity>\d*)\)" & @CRLF & _
"\* IRONWORKS DRing \(Amount: 1,599\.00 USD, Special Quantity: (?<DQuantity>\d*)\)" & @CRLF & _
"\* IRONWORKS LRing \(Amount: 399\.00 USD, Special Quantity: (?<LQuantity>\d*)\)" & @CRLF & _
"\* IRONWORKS SRing \(Amount: 1,199\.00 USD, Special Quantity: (?<SQuantity>\d*)"
Local $sString = "* S12 (Amount: 730.00 USD, Special Quantity: 1546)" & @CRLF & _
"* IRONWORKS DRing (Amount: 1,599.00 USD, Special Quantity: 1)" & @CRLF & _
"* IRONWORKS LRing (Amount: 399.00 USD, Special Quantity: 1)" & @CRLF & _
"* IRONWORKS SRing (Amount: 1,199.00 USD, Special Quantity: 1) **"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")