$re = '/\* S12 \(Amount: 730\.00 USD, Special Quantity: (?<S12Quantity>\d*)\)
\* IRONWORKS DRing \(Amount: 1,599\.00 USD, Special Quantity: (?<DQuantity>\d*)\)
\* IRONWORKS LRing \(Amount: 399\.00 USD, Special Quantity: (?<LQuantity>\d*)\)
\* IRONWORKS SRing \(Amount: 1,199\.00 USD, Special Quantity: (?<SQuantity>\d*)/m';
$str = '* S12 (Amount: 730.00 USD, Special Quantity: 1546)
* IRONWORKS DRing (Amount: 1,599.00 USD, Special Quantity: 1)
* IRONWORKS LRing (Amount: 399.00 USD, Special Quantity: 1)
* IRONWORKS SRing (Amount: 1,199.00 USD, Special Quantity: 1) **';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);