import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\* S12 \\(Amount: 730\\.00 USD, Special Quantity: (?<S12Quantity>\\d*)\\)\n"
+ "\\* IRONWORKS DRing \\(Amount: 1,599\\.00 USD, Special Quantity: (?<DQuantity>\\d*)\\)\n"
+ "\\* IRONWORKS LRing \\(Amount: 399\\.00 USD, Special Quantity: (?<LQuantity>\\d*)\\)\n"
+ "\\* IRONWORKS SRing \\(Amount: 1,199\\.00 USD, Special Quantity: (?<SQuantity>\\d*)";
final String string = "* S12 (Amount: 730.00 USD, Special Quantity: 1546)\n"
+ "* IRONWORKS DRing (Amount: 1,599.00 USD, Special Quantity: 1)\n"
+ "* IRONWORKS LRing (Amount: 399.00 USD, Special Quantity: 1)\n"
+ "* IRONWORKS SRing (Amount: 1,199.00 USD, Special Quantity: 1) **";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}