const regex = /\* S12 \(Amount: 730\.00 USD, Special Quantity: (?<S12Quantity>\d*)\)
\* IRONWORKS DRing \(Amount: 1,599\.00 USD, Special Quantity: (?<DQuantity>\d*)\)
\* IRONWORKS LRing \(Amount: 399\.00 USD, Special Quantity: (?<LQuantity>\d*)\)
\* IRONWORKS SRing \(Amount: 1,199\.00 USD, Special Quantity: (?<SQuantity>\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\* S12 \\(Amount: 730\\.00 USD, Special Quantity: (?<S12Quantity>\\d*)\\)
\\* IRONWORKS DRing \\(Amount: 1,599\\.00 USD, Special Quantity: (?<DQuantity>\\d*)\\)
\\* IRONWORKS LRing \\(Amount: 399\\.00 USD, Special Quantity: (?<LQuantity>\\d*)\\)
\\* IRONWORKS SRing \\(Amount: 1,199\\.00 USD, Special Quantity: (?<SQuantity>\\d*)', 'gm')
const str = `* S12 (Amount: 730.00 USD, Special Quantity: 1546)
* IRONWORKS DRing (Amount: 1,599.00 USD, Special Quantity: 1)
* IRONWORKS LRing (Amount: 399.00 USD, Special Quantity: 1)
* IRONWORKS SRing (Amount: 1,199.00 USD, Special Quantity: 1) **`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}