using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"path\=\"".*\\(?<folder>[^\\]+)\\\w+\.\w+\""";
string input = @"2023-08-02 host1 11.11.11 10.2.34.12 path=""C:\Program Files\folder 1\my_file.docx"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}