import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "path\\=\\\".*\\\\(?<folder>[^\\\\]+)\\\\\\w+\\.\\w+\\\"";
final String string = "2023-08-02 host1 11.11.11 10.2.34.12 path=\"C:\\Program Files\\folder 1\\my_file.docx\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}