// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)path\=\".*\\(?<folder>[^\\]+)\\\w+\.\w+\""#).unwrap();
let string = "2023-08-02 host1 11.11.11 10.2.34.12 path=\"C:\\Program Files\\folder 1\\my_file.docx\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}