$re = '/path\=\".*\\\\(?<folder>[^\\\\]+)\\\\\w+\.\w+\"/m';
$str = '2023-08-02 host1 11.11.11 10.2.34.12 path="C:\\Program Files\\folder 1\\my_file.docx",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);