$re = '/\d{1,2}\s\w{3,5}\s\d{2,4}/m';
$str = '26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);