import re
regex = re.compile(r"\d{1,2}\s\w{3,5}\s\d{2,4}", flags=re.MULTILINE)
test_str = "26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")