// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}\s\w{3,5}\s\d{2,4}").unwrap();
let string = "26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}