use strict;
my $str = 'this is my sentence \\"course of math\\" of this year';
my $regex = qr/"(\w+)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";