re = /"(\w+)/
str = 'this is my sentence \\"course of math\\" of this year'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result