import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*[a-zA-Z_0-9] = [a-zA-Z0-9 óńęąłśćżź\\-.,?'\":\\\\/<>_\\(\\)\\!=]+)|(#[a-zA-Z0-9 ÓŃĘĄŁŚĆŻŹóńęąłśćżź\\-.,?'\":\\\\/<>_\\(\\)\\!=]+)$";
final String string = "# Etykieta na przycisku Usuń kanał.\n"
+ "label_button_delete_channel = Usuń ten kanał\n"
+ "# Przycisk etykieta save zmiany kanału.\n"
+ "label_button_save_channel = Zapisz zmiany\n"
+ "# Etykieta na przycisk używany do wysyłania kanału zaprosić.\n"
+ "label_button_send_invite_channel = Wyślij zaprosić\n"
+ "# Wiadomość dla użytkownika przed wysłaniem zaproszenia do kanału.\n"
+ "msg_send_invite_channel = link aktywacyjny zostanie wysłany na adres e-mail. Odbiorca musi w link w mailu, i potwierdzić aktywację.\n"
+ "# Sekcja konfiguracji Homecoming Komunikat pomocy.\n"
+ "label_homecoming_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji, w przypadku gdy ktoś wraca do domu.\n"
+ "# Pomoc wiadomość systemt sekcji konfiguracji zdrowia.\n"
+ "label_systemhealth_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji w przypadku, gdy system wymaga uwagi.\n"
+ "# Sekcja konfiguracji dzienników Komunikat pomocy połączeń.\n"
+ "label_calllogs_configuration_description = Można określić, który można zadzwonić bezpośrednio z aplikacji w przypadku otrzymania wydarzenie rejestr połączeń podczas twojej nieobecności.\n"
+ "# Sekcja konfiguracji powiadomienia Komunikat pomocy.\n"
+ "label_notifications_configuration_description = Możesz skonfigurować, którzy zostaną powiadomieni przez system elementów Gigaset poprzez powiadomienia Push lub e-mail, gdy ktoś przychodzi do domu lub system wymaga uwagi lub zdarzenie rejestru połączeń zostanie odebrany podczas twojej nieobecności.\n"
+ "# Tekst # Etykieta na adres e-mail powiadomienia e-mail\n"
+ "label_email_channel_address = Adres e-mail\n"
+ "# Etykieta na informację, tytułu w sekcji konfiguracji\n"
+ "label_email_notifications = Powiadomienia e-mail\n"
+ "# Opis powiadomień e-mail przycisk pomóc\n"
+ "label_notifications_email_configuration = Możesz skonfigurować, którzy zostaną powiadomieni przez system elementów Gigaset poprzez e-mail, gdy ktoś przychodzi do domu lub system wymaga uwagi lub zdarzenie rejestru połączeń zostanie odebrany podczas twojej nieobecności.\n"
+ "# Tekst do wyświetlenia w tabeli opcji wejść na progu\n"
+ "label_zone_threshold_title = Próg\n"
+ "# Tekst na ekranie o tytuł progu strefy\n"
+ "label_zone_threshold_screen_title = Próg Strefa\n"
+ "label_lang_pl = Polski";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}