using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(function*)?(I\w*))";
string input = @"function testFunction (ITest, one, ISettings, two, IParam1, three, Iparam2){";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}