package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(function*)?(I\w*))`)
var str = `function testFunction (ITest, one, ISettings, two, IParam1, three, Iparam2){`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}