$re = '/(?:(function*)?(I\w*))/';
$str = 'function testFunction (ITest, one, ISettings, two, IParam1, three, Iparam2){';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);