re = /(?:(function*)?(I\w*))/
str = 'function testFunction (ITest, one, ISettings, two, IParam1, three, Iparam2){'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end